在 Windows 下为 PHP 5.4 安装 PEAR、PHPUnit 及 phpDoc2

1.安装PEAR

官方网站: http://pear.php.net/

PHP 5.4 的 Windows 包中没有自带 PEAR,下载 http://pear.php.net/go-pear.phar 到PHP目录,并运行:

php go-pear.phar

安装完成后PHP目录下会产生一个名为 pear.bat 的批处理文件,并且会在系统中添加以下环境变量(用户变量,假定PHP安装在C:php):

PHP_PEAR_BIN_DIR=C:php
PHP_PEAR_DATA_DIR=C:phpdata
PHP_PEAR_DOC_DIR=C:phpdocs
PHP_PEAR_INSTALL_DIR=C:phppear
PHP_PEAR_PHP_BIN=C:phpphp.exe
PHP_PEAR_SYSCONF_DIR=C:php
PHP_PEAR_TEST_DIR=C:phptests

在写使用了 PHP 的批处理脚本时可以好好利用下这些环境变量。

在命令行输入:

pear version

如果有显示类似如下信息,说明 PEAR 已经成功安装:

PEAR Version: 1.9.4
PHP Version: 5.4.4
Zend Engine Version: 2.4.0
Running on: Windows NT ACER-TM4750G 5.1 build 2600 (Windows XP Professional Service Pack 3) i586

2.安装 PHPUnit

官方网站: http://www.phpunit.de/
PHPUnit 3.6 需要 PHP 5.2.7 (或更改版本) 但强烈推荐使用 PHP 5.3.9 (或更高版本)。

PHPUnit 使用PEAR进行安装:

pear config-set auto_discover 1
pear install pear.phpunit.de/PHPUnit

安装完成后PHP目录下会产生一个名为 phpunit.bat 的批处理文件。

在命令行输入:

phpunit --version

如果有显示类似如下信息,说明 PHPUnit 已经成功安装:

PHPUnit 3.6.11 by Sebastian Bergmann.

注意,在 PHP 官方 PEAR 频道上也有两个 PHPUnit 的包,名称分别为 PHPUnit 和 PHPUnit2 ,这两个包都是旧版本,分别是 1.x 和 2.x 的版本,如果你使用下面的方式直接安装:

pear install phpunit

那你安装的就是为 PHP 4.x 提供的旧版本 PHPUnit 1.x 了,要使用最新的 PHPUnit 3.x 版本,你需要使用 pear.phpunit.de 这个频道。

使用PHPUnit:

%PHP_PEAR_BIN_DIR%phpunit test.php

3.安装 phpDocumentor 2

官方网站: http://www.phpdoc.org/
phpDocumentor 2 是为PHP 5.3 或更高版本的所有特性生成 API 文档而创建。

phpDocumentor 2 同样使用PEAR进行安装:

pear channel-discover pear.phpdoc.org
pear install phpdoc/phpDocumentor

安装完成后PHP目录下会产生一个名为 phpdoc.bat 的批处理文件。

在命令行输入:

phpdoc --version

如果有显示类似如下信息,说明 phpDocumenter 2 已经成功安装:

phpDocumentor version 2.0.0a7

使用方法,在要生成文档的项目所在目录运行:

%PHP_PEAR_BIN_DIR%phpdoc -d . -t docs

安装的时候碰到这样一个错误:
1    No releases available for package “pear.phpunit.de/PHPUnit”
2    install failed

这个错误很有可能是本地缓存造成的,下面我们来使用
1    pear clear-cache

未经允许不得转载:SuperMan's blog » 在 Windows 下为 PHP 5.4 安装 PEAR、PHPUnit 及 phpDoc2

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址